Commit feea2ef5 authored by Marco Govoni's avatar Marco Govoni
Browse files
parents a0f40aca e20e0db3
Pipeline #2554 failed with stages
in 5 minutes and 50 seconds
......@@ -32,7 +32,7 @@ stages:
- git clone -b $CI_COMMIT_REF_NAME $CI_REPOSITORY_URL West
- cd West
- git describe
- make conf PYT=python3
- make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags --embed`"
- make all
- ls ../bin
......@@ -47,7 +47,7 @@ stages:
- ls bin
- git clone -b $CI_COMMIT_REF_NAME $CI_REPOSITORY_URL West
- cd West
- make conf PYT=python3
- make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags --embed`"
- make all > /dev/null
- useradd -m qe
- cp -r test-suite /home/qe
......
......@@ -11,6 +11,8 @@ The current list of developers, in alphabetical order:
- Sijia Dong (Argonne National Laboratory)
- Marco Govoni (Argonne National Laboratory and University of Chicago)
- Lan Huang (Argonne National Laboratory)
- Yu Jin (University of Chicago)
- He Ma (University of Chicago)
- Han Yang (University of Chicago)
......
Change Log
==========
v4.2.1 (2020/10/19)
-------------------
- Added support for python 3.8 (--embed)
- Updated scripts for RCC-Midway and MacOSX
- Solved bugs in reporting conf layer in Makefile
- Updated documentation
v4.2.0 (2020/07/03)
-------------------
......
......@@ -13,7 +13,7 @@ Configure QuantumEspresso by running the ``configure`` script that comes with th
$ git clone -b 'qe-6.1.0' --single-branch --depth 1 https://gitlab.com/QEF/q-e.git QEdir
$ cd QEdir
$ git clone -b 'v4.1.0' --single-branch --depth 1 http://greatfire.uchicago.edu/west-public/West.git West
$ git clone -b 'v4.2.1' --single-branch --depth 1 http://greatfire.uchicago.edu/west-public/West.git West
$ ./configure
.. note::
......@@ -26,7 +26,7 @@ It's now time to create the ``pw.x``, ``wstat.x``, ``wfreq.x``, and ``westpp.x``
$ cd QEdir
$ make pw
$ cd QEdir/West
$ make conf PYT=python3
$ make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags --embed`"
$ make all
You have succefully installed QuantumEspresso and WEST if you see the executables ``pw.x``, ``wstat.x``, ``wfreq.x``, and ``westpp.x`` created in the QEdir/bin directory.
......
......@@ -26,12 +26,13 @@ WEST executables can be compiled using the following script:
export MY_LIB_PATH=/Users/myname/LIBRARIES
export CPP='cpp-9'
export CC='gcc-9'
export CPP='cpp-10'
export CC='gcc-10'
export CFLAGS='-m64 -Wall -Wextra'
export F77='mpif77'
export FFLAGS='-m64 -fopenmp'
export FC='mpif90'
export MPIF90='mpif90'
export F90='mpif90'
export FCFLAGS='-m64 -fopenmp -Wall -fbacktrace -fbounds-check'
export BLAS_LIBS=${MY_LIB_PATH}/BLAS/libblas.a
......@@ -44,7 +45,7 @@ WEST executables can be compiled using the following script:
make -j 4 pw
cd West
make conf PYT=python3
make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags --embed`"
make all
To use the script do:
......
......@@ -20,8 +20,8 @@ WEST executables can be compiled using the following script:
$ cat build_west.sh
#!/bin/bash
module load intelmpi/5.1+intel-16.0 mkl/2017.up4 Anaconda3/5.1.0
module load intelmpi/5.1+intel-16.0 mkl/2017.up4 python/cpython-3.8.5
export F77=mpiifort
export CC=mpiicc
export MPIF90=mpiifort
......@@ -34,11 +34,11 @@ WEST executables can be compiled using the following script:
export LAPACK_LIBS=" "
export SCALAPACK_LIBS=" -lmkl_scalapack_lp64 -Wl,--start-group -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lmkl_blacs_intelmpi_lp64 -Wl,--end-group"
./configure --enable-parallel --with-scalapack --enable-openmp
make -j 6 pw
./configure --enable-openmp=yes --enable-parallel=yes --with-scalapack=intel --with-hdf5=no
make -j 2 pw
cd West
make conf PYT=python3
make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags --embed`"
make all
To use the script do:
......@@ -63,7 +63,7 @@ The following is an example executable script `run_west.sh` to run the `wstat.x`
#SBATCH --ntasks-per-node=28
#SBATCH --cpus-per-task=1
module load intelmpi/5.1+intel-16.0 mkl/2017.up4 Anaconda3/5.1.0
module load intelmpi/5.1+intel-16.0 mkl/2017.up4 python/cpython-3.8.5
export OMP_NUM_THREADS=$SLURM_CPUS_PER_TASK
NTASKS=$(($SLURM_NTASKS_PER_NODE * $SLURM_JOB_NUM_NODES))
......
......@@ -32,7 +32,7 @@ WEST executables can be compiled using the following script:
make pw -j 16
cd West
make conf PYT=python3
make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags`"
make all
To use the script do:
......
......@@ -6,7 +6,7 @@ default :
@echo "Welcome to WEST!"
@echo ' '
@echo 'to install WEST, type at the shell prompt:'
@echo ' make conf PYT=python-3'
@echo ' make conf PYT=python3 PYT_LDFLAGS="`python3-config --ldflags --embed`"'
@echo ' make [-j] target'
@echo ' '
@echo 'where target identifies one or multiple packages'
......@@ -31,7 +31,7 @@ conf:
@echo " " > west_make.inc
@echo WESTDIR=`pwd` >> west_make.inc
@echo PYT=${PYT} >> west_make.inc
@if [ -z "${PYT_LDFLAGS}" ] ; then echo PYT_LDFLAGS="`${PYT}-config --ldflags`" >> west_make.inc ; else echo PYT_LDFLAGS=${PYT_LDFLAGS} >> west_make.inc ; fi
@echo PYT_LDFLAGS=${PYT_LDFLAGS} >> west_make.inc
@echo " "
@echo "Generated file: west_make.inc"
@cat west_make.inc
......@@ -92,6 +92,7 @@ report_build_vars \
pytools_do
wstat: \
pytools \
libraries_do \
modules_do \
tools_do \
......
WEST.egg-info/
dist/
files.txt
import json
import sys
import os.path
def main():
fname = str(sys.argv[1])
key = str(sys.argv[2])
if os.path.isfile(fname):
with open(fname,"r") as file:
data = json.load(file)
else :
print("Cannot find FILE: ",fname)
print(data[key])
if __name__ == "__main__":
main()
from setuptools import setup
from setuptools import find_packages
import json
with open('../VERSION.json',"r") as file:
data = json.load(file)
setup(name=data["name"],
version=data["version"],
packages=find_packages(),
description='installation script for WEST',
url=data["url"],
author='Marco Govoni',
author_email='mgovoni@anl.gov',
license=data["license"],
install_requires=[
'numpy',
'scipy',
'matplotlib',
'pyyaml',
'datetime',
'setuptools',
'sphinx_rtd_theme'
],
python_requires='>=3.6, <4',
zip_safe=True)
{
"name" : "WEST",
"version" : "4.2.0",
"version" : "4.2.1",
"url" : "http://west-code.org",
"license" : "GPLv3"
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment